Feed on
Posts
Comments


OpenSprinkler Online User Manual



Videos

Documents

Start with Basics

 
 

12 Responses to “OpenSprinkler Online User Manual”

  1. Roland Schabram says:

    Dear Ray,

    I just finished to build my v1.2u board and now when testing it run into the following problems:

    First of all I do not have internet connectivity. The LCD screen shows ‘Network init failed!’ after a while when using DHCP. Static IP address does not work either. I noticed that none of the two built in LED’s in the Ethernet socket lights up.

    The manual mode does also not seem to work. When pressing B1 it only briefly shows me the IP address 0.0.0.0 but it does not allow me to schedule valve operation.

    Best regards,
    Roland

    • ray says:

      Roland,
      - I suggest that you use static IP first. To do so, *hold* B3 while powering up the controller, you will enter Option Setup. Then click B3 to navigate to ‘Use DHCP’ option, and press B1 or B2 to set it to ‘No’. Next, set the static ip and gateway ip according to your local network. Finally, *hold* B3 will activate the settings. Note that the ips must be set correctly according to your router configuration. If you are unsure, check the router’s configuration page. For example, on my router, the client IPs are all in the range 192.168.1.1xx, and the gateway ip is 192.168.1.66.

      - The two built-in LEDs on the RJ45 jack are not internally connected to the ENC28J controller, so you won’t see them light up. However, the LED on the router’s port (i.e. the port you connected to OpenSprinkler) should light up. If it doesn’t, let me know.

      - The software shipped with v1.2u does not have manual mode. Instead, it has a self-test mode, which is activated by *holding* B1 while powering up the controller. It will then enter a self-test mode where each station is turned on for 5 seconds.

      - I suggest that you post further questions to the forum: http://groups.google.com/group/rayshobby

  2. Ross Bell says:

    Hi Ray:
    After some frustration I was able to upload the version 1.1 interval firmware, had to use the stk500 to flash the firmware, I was wondering how change the static ip address all I get is 192 but can’t add the rest of the address. I was wondering if there is a hex for the full schedule 1.1 I can’t find it. Has been a learning experience had to re flash the bootloader ,could not get avrdude to work with the USBasp.
    Thanks again Ross Bell

    • ray says:

      Ross: to set static ip, first set ‘Use DHCP’ to ‘No’, then keep clicking on button B3 you should see see static.ip1, static.ip2…, gateway.ip1, gateway.ip2.. If you can’t find it let me know.

  3. Ross Bell says:

    Hi Ray:
    Thanks for the quick reply the web interface is working fine , have one
    question regarding valve programing regarding the Entry time below Time the
    default value was 4 hours does that mean every four hours the valve will
    activate, I changed the value 23hrs59mins since I want water only once
    during that time period. Yes I found that static setup OK, I really like
    new the scheduling firmware thank you for such a great project.

    Ross

    • ray says:

      Sure, that works. Alternatively you can just set an earlier ‘end time’ so that the program will stop executing after one watering. In any case, you can use the ‘Program Preview’ to check if the schedule is set correctly according to your need.

  4. Gary Giddings says:

    With Google Chrome on my Android Tablet, the Program Preview
    does not show the Station Delay.

    In one place you say “any modern browser” can be used.
    But, I did find the “not IE… ” elsewhere.

    Thanks again for your good work.

    • ray says:

      Well, I have an Android phone and station delay clearly shows on my browser. I will get an Android tablet and check with it. One thing to keep in mind is that if your station delay is only a few seconds, the difference will be pretty small to see on the screen. If you set station delay to be 240 seconds, it should show up clearly.

      Regarding browser, I will add terms as ‘any modern browser (except IE)’.

  5. Gary Giddings says:

    The Station Delay DOES show.
    I did not realize that the Station Delay was in seconds, not minutes.
    When I changed from 1 to 60 (one minute), the delay shows clearly.

    The only place I found the units mentioned was in the B3 options
    setting when powering on the OpenSprinkler.

    Is there a description of how the html Web pages are constructed
    and who does what to whom?
    Probably I have just not found it yet.

    Thanks again, Gary

  6. Gary Giddings says:

    Using Google Chrome on an Android touch screen tablet,
    I do not know how to “Hover on…” an option in order
    to see the equivalent of a “Tool Tip”.

    Is there any way to do that, please?
    Thanks, Gary

    • ray says:

      You arr right, ‘hovering’ doesn’t work on mobile devices. In any case, the tooltips are meant to remind you the meaning of options and acceptable range of values. It’s not meant to replace the user manual.